Hive Requirements

From Wiki

(Difference between revisions)
Jump to: navigation, search
 
(7 intermediate revisions not shown)
Line 7: Line 7:
* CentOS 5.3+
* CentOS 5.3+
* RedHat Enterprise 5.3+
* RedHat Enterprise 5.3+
-
 
+
* Debian 6.x
-
We plan to add Debian and Ubuntu support soon.
+
= Required software =
= Required software =
* yum
* yum
-
* WHM/cPanel
+
* Apache web server (without mod_ruid2)
-
* Apache web server
+
* Perl 5.8.0 or greater
* Perl 5.8.0 or greater
* PostgreSQL 8.4.* or greater  
* PostgreSQL 8.4.* or greater  
Line 19: Line 17:
* Exim MTA
* Exim MTA
* At least one external IP address (NAT/LAN-based systems will NOT work)
* At least one external IP address (NAT/LAN-based systems will NOT work)
-
* MariaDB 5.2 or Percona-Server 5.1.49 if you want MySQL statistics
+
* MariaDB 5.2 or Percona-Server 5.1.49 (only if you want MySQL statistics)
 +
* Disabled SELinux
 +
* gcc (needed to build Perl modules and will be automatically installed if not present on the server)
 +
 
 +
1H Hive is compatible with the following control panels: cPanel, Plesk and DirectAdmin. It can also be installed on servers without any control panel software.

Latest revision as of 00:36, 11 October 2016

Hardware

OS

Required software

1H Hive is compatible with the following control panels: cPanel, Plesk and DirectAdmin. It can also be installed on servers without any control panel software.

Personal tools
Namespaces
Variants
Actions
Navigation
Toolbox